aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/gdbm/Makefile24
-rw-r--r--databases/gdbm/pkg-descr13
2 files changed, 16 insertions, 21 deletions
diff --git a/databases/gdbm/Makefile b/databases/gdbm/Makefile
index 6923395b3bc7..33685812ce31 100644
--- a/databases/gdbm/Makefile
+++ b/databases/gdbm/Makefile
@@ -7,40 +7,36 @@ CATEGORIES= databases
MASTER_SITES= GNU
MAINTAINER= gabor@FreeBSD.org
-COMMENT= The GNU database manager
+COMMENT= GNU database manager
-OPTIONS_DEFINE= COMPAT
-COMPAT_DESC= dbm/ndbm compatibility
+LICENSE= GPLv3
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
+
INFO= gdbm
MAN3= gdbm.3
+OPTIONS_DEFINE= COMPAT
+COMPAT_DESC= Enable dbm/ndbm compatibility
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCOMPAT}
-CONFIGURE_ARGS+=--enable-libgdbm-compat
+CONFIGURE_ARGS= --enable-libgdbm-compat
PLIST_SUB= GDBM_COMPAT=""
.else
PLIST_SUB= GDBM_COMPAT="@comment "
.endif
-pre-everything::
-.if ! ${PORT_OPTIONS:MCOMPAT}
- @${ECHO_MSG}
- @${ECHO_MSG} "If you need UNIX dbm/ndbm compatibility functions,"
- @${ECHO_MSG} "use \"make WITH=COMPAT\""
- @${ECHO_MSG}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|LIBS = @LIBS@ -lc|LIBS = @LIBS@|" \
- -e "s|BINOWN = bin|BINOWN = root|" -e "s|BINGRP = bin|BINGRP = wheel|" \
- -e "s|libgdbm.la libgdbm_compat.la|libgdbm.la libgdbm_compat.la gdbm.info|" \
+ -e "s|BINOWN = bin|BINOWN = root|" -e "s|BINGRP = bin|BINGRP = wheel|" \
+ -e "s|libgdbm.la libgdbm_compat.la|libgdbm.la libgdbm_compat.la gdbm.info|" \
${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/databases/gdbm/pkg-descr b/databases/gdbm/pkg-descr
index bbb93ea101df..1804ef5e02b1 100644
--- a/databases/gdbm/pkg-descr
+++ b/databases/gdbm/pkg-descr
@@ -1,9 +1,8 @@
-The GNU `dbm' is a library of database functions that use extendible
-hashing and works similar to the standard UNIX `dbm' functions.
-These routines are provided to a programmer needing to create and
-manipulate a hashed database.
+The GNU dbm is a library of database functions that use extensible hashing
+and works similar to the standard UNIX dbm functions. These routines are
+provided to a programmer needing to create and manipulate a hashed database.
-This library exists in the FreeBSD base collection, but the GNU
-version has added functionality that is sometimes useful.
+This library exists in the FreeBSD base collection, but the GNU version has
+added functionality that is sometimes useful.
-WWW: http://www.gnu.org/software/gdbm/gdbm.html
+WWW: http://www.gnu.org/software/gdbm/