aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/glom/Makefile41
-rw-r--r--databases/glom/distinfo2
-rw-r--r--databases/glom/pkg-descr21
-rw-r--r--databases/glom/pkg-plist38
5 files changed, 103 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 02dac87b2f4d..070838ef5f18 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -55,6 +55,7 @@
SUBDIR += gbib
SUBDIR += gdbm
SUBDIR += gigabase
+ SUBDIR += glom
SUBDIR += gmysql
SUBDIR += gnats
SUBDIR += gnats4
diff --git a/databases/glom/Makefile b/databases/glom/Makefile
new file mode 100644
index 000000000000..3880f62dd413
--- /dev/null
+++ b/databases/glom/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: glom
+# Date created: 24 April, 2005
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/databases/glom/Makefile,v 1.4 2005/07/01 17:55:37 marcus Exp $
+#
+
+PORTNAME= glom
+PORTVERSION= 0.8.30
+CATEGORIES= databases gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.8
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME database designed
+
+LIB_DEPENDS= bakery-2.3:${PORTSDIR}/x11-toolkits/bakery \
+ gdamm-1.3:${PORTSDIR}/databases/libgdamm
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_PYTHON= yes
+
+USE_AUTOTOOLS= libtool:15
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix pygnomeextras
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+INSTALLS_OMF= yes
+
+.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} < 500000)
+BROKEN= "Doesn't play well with 4.X."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/glom/distinfo b/databases/glom/distinfo
new file mode 100644
index 000000000000..bb867efaab54
--- /dev/null
+++ b/databases/glom/distinfo
@@ -0,0 +1,2 @@
+MD5 (glom-0.8.30.tar.bz2) = 5cd522f7f6bb34667bc184fb42a4ce8d
+SIZE (glom-0.8.30.tar.bz2) = 593130
diff --git a/databases/glom/pkg-descr b/databases/glom/pkg-descr
new file mode 100644
index 000000000000..6974a6efb78e
--- /dev/null
+++ b/databases/glom/pkg-descr
@@ -0,0 +1,21 @@
+With Glom you can design table definitions and the relationships
+between them, plus arrange the fields on the screen. You can edit
+and search the data in those tables, and specify field values in
+terms of other fields. It's as easy as it should be.
+
+The design is loosely based on FileMaker Pro, with the added
+advantage of separation between interface and data. Its simple
+framework should be enough to implement most database
+applications. Without Glom these systems normally consist of lots
+of repetitive, unmaintainable code.
+
+Glom-specific data such as the relationship definitions is saved
+in the Glom document. Glom re-connects to the database server
+when it loads a previous Glom document. The document is in XML
+format.
+
+Glom uses the PostgreSQL database backend but it can not edit
+databases that it did not create, because it uses only a simple
+subset of Postgres functionality.
+
+WWW: http://www.glom.org/
diff --git a/databases/glom/pkg-plist b/databases/glom/pkg-plist
new file mode 100644
index 000000000000..7ef7debe5dd5
--- /dev/null
+++ b/databases/glom/pkg-plist
@@ -0,0 +1,38 @@
+bin/glom
+%%PYTHON_SITELIBDIR%%/glom.so
+share/gnome/application-registry/glom.applications
+share/gnome/apps/Applications/glom.desktop
+share/gnome/glom/glade/glom.glade
+share/gnome/glom/glom_document.dtd
+share/gnome/glom/xslt/print_details_to_html.xsl
+share/gnome/glom/xslt/print_report_to_html.xsl
+share/gnome/help/glom/C/figures/start.png
+share/gnome/help/glom/C/glom.xml
+share/gnome/help/glom/C/legal.xml
+share/gnome/mime-info/glom.keys
+share/gnome/mime-info/glom.mime
+share/gnome/omf/glom/glom-C.omf
+share/locale/cs/LC_MESSAGES/glom.mo
+share/locale/de/LC_MESSAGES/glom.mo
+share/locale/en_CA/LC_MESSAGES/glom.mo
+share/locale/en_GB/LC_MESSAGES/glom.mo
+share/locale/es/LC_MESSAGES/glom.mo
+share/locale/fr/LC_MESSAGES/glom.mo
+share/locale/gu/LC_MESSAGES/glom.mo
+share/locale/it/LC_MESSAGES/glom.mo
+share/locale/nl/LC_MESSAGES/glom.mo
+share/locale/pa/LC_MESSAGES/glom.mo
+share/locale/pt/LC_MESSAGES/glom.mo
+share/locale/pt_BR/LC_MESSAGES/glom.mo
+share/locale/rw/LC_MESSAGES/glom.mo
+share/locale/sq/LC_MESSAGES/glom.mo
+share/locale/sv/LC_MESSAGES/glom.mo
+share/locale/tr/LC_MESSAGES/glom.mo
+share/locale/zh_CN/LC_MESSAGES/glom.mo
+share/mime/packages/glom.xml
+@dirrm share/gnome/help/glom/C/figures
+@dirrm share/gnome/help/glom/C
+@dirrm share/gnome/help/glom
+@dirrm share/gnome/glom/xslt
+@dirrm share/gnome/glom/glade
+@dirrm share/gnome/glom