aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/sqlite3/Makefile4
-rw-r--r--databases/sqlite3/distinfo6
-rw-r--r--databases/sqlite3/files/patch-Makefile.in9
3 files changed, 10 insertions, 9 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 8ef371f6031d..d3eab884bebf 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sqlite3
-PORTVERSION= 3.6.19
+PORTVERSION= 3.6.23.1
CATEGORIES= databases
MASTER_SITES= http://www.sqlite.org/
DISTNAME= sqlite-${PORTVERSION}
@@ -21,7 +21,6 @@ USE_GNOME= pkgconfig
USE_LDCONFIG= YES
GNU_CONFIGURE= YES
USE_GNOME= gnomehack
-USE_TCL_BUILD= 84+
CONFIGURE_ENV+= TCLSH_CMD="${TCLSH}" \
TCLLIBDIR="${PREFIX}/lib/${PORTNAME}" \
ac_cv_search_pthread_create=""
@@ -60,6 +59,7 @@ CONFIGURE_ARGS+= --enable-tempstore=yes
.if defined(WITH_TCLWRAPPER)
CATEGORIES+= lang tcl
COMMENT+= with TCL Wrapper
+USE_TCL_BUILD= 84+
USE_TCL_RUN= 84+
CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR}
PLIST_SUB+= WITH_TCLWRAPPER=""
diff --git a/databases/sqlite3/distinfo b/databases/sqlite3/distinfo
index 502da0906432..af281aa5262c 100644
--- a/databases/sqlite3/distinfo
+++ b/databases/sqlite3/distinfo
@@ -1,3 +1,3 @@
-MD5 (sqlite-3.6.19.tar.gz) = aa03cc24a52851bb204fc1e489e195e8
-SHA256 (sqlite-3.6.19.tar.gz) = 7d8649c44fb97b874aa59144faaeb2356ec1fc6a8a7baa1d16e9ff5f1e097003
-SIZE (sqlite-3.6.19.tar.gz) = 2942005
+MD5 (sqlite-3.6.23.1.tar.gz) = d99f1b31da0eb33271464bee15cec701
+SHA256 (sqlite-3.6.23.1.tar.gz) = 1a0517438a573a68ab73e8ed75d194086d55d75883542ab1d5ae1080bbddd492
+SIZE (sqlite-3.6.23.1.tar.gz) = 3086807
diff --git a/databases/sqlite3/files/patch-Makefile.in b/databases/sqlite3/files/patch-Makefile.in
index f34f6a1ae9c6..ae12f5fa13b2 100644
--- a/databases/sqlite3/files/patch-Makefile.in
+++ b/databases/sqlite3/files/patch-Makefile.in
@@ -1,11 +1,12 @@
---- Makefile.in.orig 2009-09-17 13:41:21.000000000 +0200
-+++ Makefile.in 2009-09-17 13:45:38.000000000 +0200
-@@ -687,7 +687,7 @@
+--- ./Makefile.in.orig 2010-03-30 17:56:53.366241027 +0200
++++ ./Makefile.in 2010-03-30 18:05:42.477723394 +0200
+@@ -689,7 +689,8 @@
$(LTCOMPILE) $(TEMP_STORE) -c $(TOP)/src/status.c
sqlite3.h: $(TOP)/src/sqlite.h.in $(TOP)/manifest.uuid $(TOP)/VERSION
- tclsh $(TOP)/tool/mksqlite3h.tcl $(TOP) >sqlite3.h
-+ $(TCLSH_CMD) $(TOP)/tool/mksqlite3h.tcl $(TOP) >sqlite3.h
++ sed -e s/--VERS--/$(RELEASE)/ $(TOP)/src/sqlite.h.in | \
++ sed -e s/--VERSION-NUMBER--/$(VERSION_NUMBER)/ >sqlite3.h
table.lo: $(TOP)/src/table.c $(HDR)
$(LTCOMPILE) $(TEMP_STORE) -c $(TOP)/src/table.c