aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/gnatsweb4/Makefile3
-rw-r--r--databases/mrtg-mysql-load/Makefile3
-rw-r--r--databases/p5-qdbm/Makefile2
-rw-r--r--databases/postgis/Makefile4
4 files changed, 7 insertions, 5 deletions
diff --git a/databases/gnatsweb4/Makefile b/databases/gnatsweb4/Makefile
index 97d5a7f4f39f..77ad606931de 100644
--- a/databases/gnatsweb4/Makefile
+++ b/databases/gnatsweb4/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
USE_APACHE_RUN= 22+
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
CGI_DIR?= ${WWWDIR}/cgi-bin
diff --git a/databases/mrtg-mysql-load/Makefile b/databases/mrtg-mysql-load/Makefile
index 603985e5e8f9..549dfdd44e4a 100644
--- a/databases/mrtg-mysql-load/Makefile
+++ b/databases/mrtg-mysql-load/Makefile
@@ -13,9 +13,10 @@ COMMENT= A MySQL load analysis fetcher for MRTG
RUN_DEPENDS= mrtg:${PORTSDIR}/net-mgmt/mrtg
+USES= perl5
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_MYSQL= yes
MAN1= ${PORTNAME}.1
diff --git a/databases/p5-qdbm/Makefile b/databases/p5-qdbm/Makefile
index e9dcc808d8f6..8f91098dfe32 100644
--- a/databases/p5-qdbm/Makefile
+++ b/databases/p5-qdbm/Makefile
@@ -10,7 +10,7 @@ PKGNAMEPREFIX= p5-
COMMENT= Perl API for QDBM
SLAVEPORT= perl
-USE_PERL5= yes
+USES= perl5
MASTERDIR= ${.CURDIR}/../../databases/qdbm
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/perl
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index ec7ea9cabeb6..b28343a2e08c 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -17,12 +17,12 @@ RUN_DEPENDS= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
CONFLICTS= postgis-2.*
-USES= bison iconv gmake
+USES= bison iconv gmake perl5
USE_GNOME= libxml2
USE_PGSQL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
OPTIONS_DEFINE= LOADERGUI
LOADERGUI_DESC= Enable shp2pgsql-gui