aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Test-postgresql/Makefile27
-rw-r--r--databases/p5-Test-postgresql/distinfo2
-rw-r--r--databases/p5-Test-postgresql/pkg-descr4
-rw-r--r--databases/p5-Test-postgresql/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 9d6101938fda..55827e14f781 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -450,6 +450,7 @@
SUBDIR += p5-Test-Cukes
SUBDIR += p5-Test-Database
SUBDIR += p5-Test-DatabaseRow
+ SUBDIR += p5-Test-postgresql
SUBDIR += p5-Text-Query-SQL
SUBDIR += p5-Tie-DBI
SUBDIR += p5-Time-Piece-MySQL
diff --git a/databases/p5-Test-postgresql/Makefile b/databases/p5-Test-postgresql/Makefile
new file mode 100644
index 000000000000..47d3b0e2cf0b
--- /dev/null
+++ b/databases/p5-Test-postgresql/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Test::postgresql
+# Date created: 26 Dec 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-postgresql
+PORTVERSION= 0.09
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension of postgresql runner for tests
+
+RUN_DEPENDS= \
+ p5-Class-Accessor-Lite>0:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
+ p5-DBI>0:${PORTSDIR}/databases/p5-DBI \
+ p5-DBD-Pg>0:${PORTSDIR}/databases/p5-DBD-Pg
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::postgresql.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Test-postgresql/distinfo b/databases/p5-Test-postgresql/distinfo
new file mode 100644
index 000000000000..9f8501d936a0
--- /dev/null
+++ b/databases/p5-Test-postgresql/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-postgresql-0.09.tar.gz) = 976366db055128c23221cd47f70e74d18bcc8ef3f6e1d202428923457960ab1d
+SIZE (Test-postgresql-0.09.tar.gz) = 18181
diff --git a/databases/p5-Test-postgresql/pkg-descr b/databases/p5-Test-postgresql/pkg-descr
new file mode 100644
index 000000000000..ee5ab41396bf
--- /dev/null
+++ b/databases/p5-Test-postgresql/pkg-descr
@@ -0,0 +1,4 @@
+Test::postgresql automatically setups a postgresql instance in a
+temporary directory, and destroys it when the perl script exits.
+
+WWW: http://search.cpan.org/dist/Test-postgresql/
diff --git a/databases/p5-Test-postgresql/pkg-plist b/databases/p5-Test-postgresql/pkg-plist
new file mode 100644
index 000000000000..671bcab96517
--- /dev/null
+++ b/databases/p5-Test-postgresql/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/postgresql/.packlist
+%%SITE_PERL%%/Test/postgresql.pm
+@dirrmtry %%SITE_PERL%%/Test
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/postgresql
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test