aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql41-server/files/patch-ndb::src::mgmclient::main.cpp11
-rw-r--r--databases/mysql41-server/pkg-plist3
2 files changed, 14 insertions, 0 deletions
diff --git a/databases/mysql41-server/files/patch-ndb::src::mgmclient::main.cpp b/databases/mysql41-server/files/patch-ndb::src::mgmclient::main.cpp
new file mode 100644
index 000000000000..ef1f6711f469
--- /dev/null
+++ b/databases/mysql41-server/files/patch-ndb::src::mgmclient::main.cpp
@@ -0,0 +1,11 @@
+--- ndb/src/mgmclient/main.cpp.orig Mon Jan 10 15:36:57 2005
++++ ndb/src/mgmclient/main.cpp Mon Jan 10 15:37:26 2005
+@@ -122,7 +122,7 @@
+ }
+ #ifdef HAVE_READLINE
+ /* Get a line from the user. */
+- line_read = readline (prompt);
++ line_read = readline ((char *)prompt);
+ /* If the line has any text in it, save it on the history. */
+ if (line_read && *line_read)
+ add_history (line_read);
diff --git a/databases/mysql41-server/pkg-plist b/databases/mysql41-server/pkg-plist
index d80681170ab8..d470f6b2a260 100644
--- a/databases/mysql41-server/pkg-plist
+++ b/databases/mysql41-server/pkg-plist
@@ -20,6 +20,7 @@ bin/mysqld_safe
%%NDB%%bin/ndb_select_all
%%NDB%%bin/ndb_select_count
%%NDB%%bin/ndb_show_tables
+%%NDB%%bin/ndb_test_platform
%%NDB%%bin/ndb_waiter
bin/pack_isam
bin/perror
@@ -28,6 +29,8 @@ bin/resolve_stack_dump
bin/resolveip
etc/rc.d/mysql-server.sh
%%NDB%%include/mysql/ndb/mgmapi/mgmapi.h
+%%NDB%%include/mysql/ndb/mgmapi/mgmapi_config_parameters.h
+%%NDB%%include/mysql/ndb/mgmapi/mgmapi_config_parameters_debug.h
%%NDB%%include/mysql/ndb/mgmapi/mgmapi_debug.h
%%NDB%%include/mysql/ndb/ndb_types.h
%%NDB%%include/mysql/ndb/ndb_version.h