aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/py-MySQL/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/databases/py-MySQL/Makefile b/databases/py-MySQL/Makefile
index bd3957a46c59..07f8c04f9971 100644
--- a/databases/py-MySQL/Makefile
+++ b/databases/py-MySQL/Makefile
@@ -16,7 +16,12 @@ MAINTAINER= dr@domix.de
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
USE_PYTHON= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VERSION} != "python2.1"
ALL_TARGET= MySQLmodule.so
+.endif
pre-configure:
${CP} ${FILESDIR}/Setup ${WRKSRC}/Setup
@@ -34,4 +39,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>