aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Handler/Makefile28
-rw-r--r--databases/p5-DBIx-Handler/distinfo3
-rw-r--r--databases/p5-DBIx-Handler/pkg-descr4
-rw-r--r--databases/p5-DBIx-Handler/pkg-plist2
5 files changed, 38 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 156e488d8881..4fbdded98712 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -382,6 +382,7 @@
SUBDIR += p5-DBIx-Dump
SUBDIR += p5-DBIx-Ease
SUBDIR += p5-DBIx-HA
+ SUBDIR += p5-DBIx-Handler
SUBDIR += p5-DBIx-Inspector
SUBDIR += p5-DBIx-Introspector
SUBDIR += p5-DBIx-Log4perl
diff --git a/databases/p5-DBIx-Handler/Makefile b/databases/p5-DBIx-Handler/Makefile
new file mode 100644
index 000000000000..e4212432b055
--- /dev/null
+++ b/databases/p5-DBIx-Handler/Makefile
@@ -0,0 +1,28 @@
+# Created by: Sergei Vyshenski <svysh.fbsd@gmail.com>
+# $FreeBSD$
+
+PORTNAME= DBIx-Handler
+PORTVERSION= 0.14
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svysh.fbsd@gmail.com
+COMMENT= Fork-safe and easy transaction handling DBI handler
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-DBI>=1.605:databases/p5-DBI \
+ p5-DBIx-TransactionManager>=1.09:databases/p5-DBIx-TransactionManager
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite \
+ p5-Test-Requires>=0:devel/p5-Test-Requires \
+ p5-Test-SharedFork>=0.16:devel/p5-Test-SharedFork
+
+NO_ARCH= yes
+USES= perl5
+USE_PERL5= modbuildtiny
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Handler/distinfo b/databases/p5-DBIx-Handler/distinfo
new file mode 100644
index 000000000000..503dfc4ea65d
--- /dev/null
+++ b/databases/p5-DBIx-Handler/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1478493797
+SHA256 (DBIx-Handler-0.14.tar.gz) = b57ec6e0c209efde96fa253aa663a88175cdc2ff62531df165d31140c5fc14f1
+SIZE (DBIx-Handler-0.14.tar.gz) = 15722
diff --git a/databases/p5-DBIx-Handler/pkg-descr b/databases/p5-DBIx-Handler/pkg-descr
new file mode 100644
index 000000000000..e122b1ab2745
--- /dev/null
+++ b/databases/p5-DBIx-Handler/pkg-descr
@@ -0,0 +1,4 @@
+DBIx::Handler is fork-safe and easy transaction handling DBI handler.
+It provides scope base transaction, fork safe dbh handling.
+
+WWW: http://search.cpan.org/dist/DBIx-Handler/
diff --git a/databases/p5-DBIx-Handler/pkg-plist b/databases/p5-DBIx-Handler/pkg-plist
new file mode 100644
index 000000000000..2402fb640486
--- /dev/null
+++ b/databases/p5-DBIx-Handler/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/DBIx/Handler.pm
+%%PERL5_MAN3%%/DBIx::Handler.3.gz