aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/rrdtool/Makefile1
-rw-r--r--databases/rrdtool10/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/databases/rrdtool/Makefile b/databases/rrdtool/Makefile
index 9329cceb60f5..0caf8c65cc48 100644
--- a/databases/rrdtool/Makefile
+++ b/databases/rrdtool/Makefile
@@ -23,6 +23,7 @@ INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-shared --enable-local-zlib \
--program-transform-name=''
CONFIGURE_ENV= PERL=${PERL}
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS:= ${CFLAGS:N-ffast-math}
diff --git a/databases/rrdtool10/Makefile b/databases/rrdtool10/Makefile
index 9329cceb60f5..0caf8c65cc48 100644
--- a/databases/rrdtool10/Makefile
+++ b/databases/rrdtool10/Makefile
@@ -23,6 +23,7 @@ INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-shared --enable-local-zlib \
--program-transform-name=''
CONFIGURE_ENV= PERL=${PERL}
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS:= ${CFLAGS:N-ffast-math}