aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/redis-devel/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index 9c1a98cf0d31..104bdcf06bf8 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -12,8 +12,6 @@ COMMENT= Persistent key-value database with built-in net interface
LICENSE= BSD3CLAUSE
-BROKEN_FreeBSD_10_i386= undefined reference to __atomic_fetch_add_8
-
USES= execinfo
OPTIONS_DEFINE= TESTS TRIB
@@ -27,6 +25,11 @@ TRIB_DESC= Install redis-trib.rb (lang/ruby req.)
.include <bsd.port.options.mk>
+.if ${ARCH} == i386 && ! ${CFLAGS:M-march=*}
+# Needed for __atomic_fetch_add_8
+CFLAGS+= -march=i586
+.endif
+
.if ${PORT_OPTIONS:MTRIB}
CATEGORIES+= ruby
USE_RUBY= yes