aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/buoh
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/buoh')
-rw-r--r--deskutils/buoh/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/deskutils/buoh/Makefile b/deskutils/buoh/Makefile
index df48a09340b6..63de6b9a7c5d 100644
--- a/deskutils/buoh/Makefile
+++ b/deskutils/buoh/Makefile
@@ -25,6 +25,19 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
DOCS= AUTHORS COPYING ChangeLog NEWS README TODO
GCONF_SCHEMAS= buoh.schemas
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+CFLAGS+= -g
+STRIP=
+.endif
+
+pre-everything::
+.if !defined(WITH_DEBUG)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} " "
+ @${ECHO_MSG} "WITH_DEBUG=yes to enable debugging in Buoh."
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${X11BASE}/share/applications|g' \
${WRKSRC}/data/Makefile.in