aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/charmtimetracker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/charmtimetracker/Makefile')
-rw-r--r--deskutils/charmtimetracker/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/deskutils/charmtimetracker/Makefile b/deskutils/charmtimetracker/Makefile
index 4c60536db9e6..4aa063343531 100644
--- a/deskutils/charmtimetracker/Makefile
+++ b/deskutils/charmtimetracker/Makefile
@@ -2,32 +2,32 @@
# $FreeBSD$
PORTNAME= charmtimetracker
-PORTVERSION= 1.11.4
+DISTVERSION= 1.11.4
+PORTREVISION= 1
CATEGORIES= deskutils
-MAINTAINER= avg@icyb.net.ua
+MAINTAINER= adridg@FreeBSD.org
COMMENT= Time tracker
+# The top-level license file is GPLv2, but all the sources say
+# (at your option) GPLv2+ .
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++0x"
+USES= cmake:outsource compiler:c++11-lib
+# Use bundled keychain; the keychain is only used for KDAB-internal
+# features not available or configurable in the port.
+CMAKE_ARGS= -DCharm_VERSION:STRING=${PORTVERSION} \
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Keychain=TRUE
USE_GITHUB= yes
GH_ACCOUNT= KDAB
GH_PROJECT= Charm
-USES= cmake
-CMAKE_ARGS+= -DCharm_VERSION:STRING=${PORTVERSION} -DCHARM_FORCE_QT4=true
-USE_QT4= qmake_build moc_build rcc_build uic_build corelib dbus gui \
- network qtestlib script sql sql-sqlite3 xml
-USE_XORG= ice x11 xext xscrnsaver
-INSTALLS_ICONS= yes
-
-PORTDOCS= ReadMe.txt
-
-OPTIONS_DEFINE= DOCS
-
-post-install:
- ${RM} ${STAGEDIR}${DOCSDIR}/License.txt
+USE_QT5= core dbus gui \
+ network printsupport script sql sql-sqlite3 \
+ testlib widgets xml \
+ buildtools_build qmake_build
+USE_XORG= ice x11 xcb xext xscrnsaver
.include <bsd.port.mk>