aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/ganttproject/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/ganttproject/Makefile')
-rw-r--r--deskutils/ganttproject/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/deskutils/ganttproject/Makefile b/deskutils/ganttproject/Makefile
index 31e02581ee8f..4c73391eceb5 100644
--- a/deskutils/ganttproject/Makefile
+++ b/deskutils/ganttproject/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= ganttproject
-PORTVERSION= 1.9.11
+PORTVERSION= 1.10.1
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -25,7 +25,8 @@ JAVA_RUN= yes
PLIST_FILES= bin/ganttproject %%JAVAJARDIR%%/ganttproject.jar
post-patch:
- @${SED} 's,%%JAVAJARDIR%%,${JAVAJARDIR},' ${FILESDIR}/${PORTNAME} > ${WRKSRC}/${PORTNAME}
+ @${SED} 's,%%JAVAJARDIR%%,${JAVAJARDIR},; \
+ s,%%JAVA%%,${JAVA},' ${FILESDIR}/${PORTNAME} > ${WRKSRC}/${PORTNAME}
do-install:
${INSTALL_DATA} ${WRKSRC}/build/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar