aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/genius/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/genius/Makefile')
-rw-r--r--deskutils/genius/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index b5cbc89bb4b9..621031d06534 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= genius
-PORTVERSION= 1.0.17
+PORTVERSION= 1.0.18
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME \
http://ftp.5z.com/pub/genius/
@@ -19,7 +19,6 @@ RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
readline shared-mime-info tar:xz
USE_GNOME= gnomedocutils gnomeprefix gtksourceview2 gnomevfs2 vte
-USE_CSTD= gnu89
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-extra-gcc-optimization \
--disable-update-mimedb \
@@ -32,4 +31,8 @@ INSTALLS_OMF= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+post-patch:
+ @${FIND} ${WRKSRC}/gtkextra -name "*.c" | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|inline gint|gint|'
+
.include <bsd.port.mk>