aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/gnome-maps/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-maps/Makefile')
-rw-r--r--deskutils/gnome-maps/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/deskutils/gnome-maps/Makefile b/deskutils/gnome-maps/Makefile
index 0176157ac2a8..03dd2e505a83 100644
--- a/deskutils/gnome-maps/Makefile
+++ b/deskutils/gnome-maps/Makefile
@@ -1,9 +1,8 @@
# Created by: Gustau Perez <gustau.perez@gmail.com>
# $FreeBSD$
-# $MCom: ports/trunk/deskutils/gnome-maps/Makefile 20053 2014-11-10 17:13:45Z gusi $
PORTNAME= gnome-maps
-PORTVERSION= 3.14.2
+PORTVERSION= 3.16.2
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -15,16 +14,21 @@ BUILD_DEPENDS= geoclue>=0:${PORTSDIR}/net/geoclue \
itstool:${PORTSDIR}/textproc/itstool
LIB_DEPENDS= libcanberra-gtk3.so:${PORTSDIR}/audio/libcanberra-gtk3 \
libgeocode-glib.so:${PORTSDIR}/net/geocode-glib \
+ libgee-0.8.so:${PORTSDIR}/devel/libgee \
+ libchamplain-0.12.so:${PORTSDIR}/graphics/libchamplain \
+ libfolks.so:${PORTSDIR}/net-im/folks \
libgjs.so:${PORTSDIR}/lang/gjs
RUN_DEPENDS= geoclue>=0:${PORTSDIR}/net/geoclue
+PORTSCOUT= limitw:1,even
+
USES= gettext gmake libtool pathfix pkgconfig tar:xz
-USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack
+USE_GNOME= gnomedesktop3 gtk30 intlhack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-GLIB_SCHEMAS= org.gnome.maps.gschema.xml
+GLIB_SCHEMAS= org.gnome.Maps.gschema.xml
.include <bsd.port.mk>