aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/myitcrm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/myitcrm/Makefile')
-rw-r--r--deskutils/myitcrm/Makefile81
1 files changed, 65 insertions, 16 deletions
diff --git a/deskutils/myitcrm/Makefile b/deskutils/myitcrm/Makefile
index 8ff975d5d26d..ab47b39933d4 100644
--- a/deskutils/myitcrm/Makefile
+++ b/deskutils/myitcrm/Makefile
@@ -6,44 +6,93 @@
#
PORTNAME= myitcrm
-PORTVERSION= 0.2.9.1
+PORTVERSION= 0.2.9.3
CATEGORIES= deskutils
MASTER_SITES= SF/myitcrm/
-DISTNAME= MyITCRM-${PORTVERSION}
+DISTNAME= MyITCRM1-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= MYIT CRM is a CRM project designed for Computer Servicing and Repairs
+MAINTAINER= rflynn@acsalaska.net
+COMMENT= MyIT CRM is a CRM project designed for Computer Servicing and Repairs
+
+LICENSE= GPLv3
USE_ZIP= yes
-USE_PHP+= mysql
-USE_MYSQL= yes
+USE_PHP= mysql session xml
NO_BUILD= yes
-WWWOWN= www
-WWWGRP= ${WWWOWN}
+WRKSRC= ${WRKDIR}/MyITCRM-${PORTVERSION}
-PKGMESSAGE= ${WRKDIR}/${PORTNAME}/pkg-message
SUB_FILES= pkg-message
PLIST_DIRSTRY= %%WWWDIR%%
+PATCH_STRIP= -p1
+WRITEABLE= conf.php log/access.log cache
+PORTEXAMPLES= htaccess.txt
+PORTDOCS= changelog.txt README.textile
+USE_DOS2UNIX= yes
-OPTIONS= APACHE "Use Apache webserver" on \
- LIGHTTPD "Use Lighttpd webserver" off
+OPTIONS= APACHE "Use Apache webserver" on \
+ PHPMOD "Use php module for Apache" off \
+ LIGHTTPD "Use Lighttpd webserver" off \
+ NGINX "Use Nginx" off
.include <bsd.port.options.mk>
-.if defined(WITH_APACHE)
-USE_APACHE= 22
+.if defined(WITH_PHPMOD)
+WANT_PHP_MOD= yes
+.else
+WANT_PHP_CGI= yes
+.endif
+
+.if !defined(WITHOUT_APACHE)
+USE_APACHE= 22+
.endif
.if defined(WITH_LIGHTTPD)
RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
.endif
+.if defined(WITH_NGINX)
+RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx
+.endif
+
+# Set files to ignore.
+.for file in ${PORTEXAMPLES} ${PORTDOCS} LICENSE.txt
+WWW_IGNORE+= -not -name ${file}
+.endfor
+
+.if defined(MAINTAINER_MODE)
+trace-distfile: distclean
+ @cd ${.CURDIR} && make FETCH_ARGS=-vFpr makesum
+
+rm-install:
+ ${SU_CMD} '${RM} -rf ${WWWDIR}/install'
+
+.endif
do-install:
@${MKDIR} ${WWWDIR}
- @${CP} -r ${WRKDIR}/${PORTNAME}-${PORTVERSION}/* ${WWWDIR}
- @${TOUCH} ${WWWDIR}/conf.php
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR} '${WWW_IGNORE}'
+ @if [ ! -f ${WWWDIR}/conf.php ]; then \
+ ${CP} ${WWWDIR}/conf-default.php ${WWWDIR}/conf.php; \
+ fi
+.for ent in ${WRITEABLE}
+ @${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/${ent}
+ @${CHMOD} u+w ${WWWDIR}/${ent}
+.endfor
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for ex in ${PORTEXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/${ex} ${EXAMPLESDIR}
+.endfor
+.endif # NOPORTEXAMPLES
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif #NOPORTDOCS
post-install:
@${CAT} ${PKGMESSAGE}
+.if defined(MAINTAINER_MODE)
+ @${MAKE} -C ${.CURDIR} rm-install
+.endif
.include <bsd.port.mk>