aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/p5-ZConf-Runner/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/p5-ZConf-Runner/Makefile')
-rw-r--r--deskutils/p5-ZConf-Runner/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/deskutils/p5-ZConf-Runner/Makefile b/deskutils/p5-ZConf-Runner/Makefile
new file mode 100644
index 000000000000..48a2be9bc328
--- /dev/null
+++ b/deskutils/p5-ZConf-Runner/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-ZConf-Runner
+# Date created: 2009-01-14
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ZConf-Runner
+PORTVERSION= 0.0.0
+CATEGORIES= deskutils perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/V/VV/VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Run a file using a choosen methode, desktop entry or mimetype
+
+RUN_DEPENDS= ${SITE_PERL}/ZConf.pm:${PORTSDIR}/net/p5-ZConf \
+ ${SITE_PERL}/File/MimeInfo/Applications.pm:${PORTSDIR}/devel/p5-File-MimeInfo
+
+PERL_CONFIGURE= yes
+
+MAN3= ZConf::Runner.3
+
+.include <bsd.port.mk>