aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/py-dosage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/py-dosage/Makefile')
-rw-r--r--deskutils/py-dosage/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/deskutils/py-dosage/Makefile b/deskutils/py-dosage/Makefile
index 91a3bcad014a..1f3ec6335f75 100644
--- a/deskutils/py-dosage/Makefile
+++ b/deskutils/py-dosage/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dosage
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.3
CATEGORIES= deskutils python
MASTER_SITES= http://slipgate.za.net/dosage/downloads/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,9 +16,15 @@ COMMENT= An application to keep a local mirror of web comics
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+USE_REINPLACE= yes
MAN1= mainline.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' \
+ ${WRKSRC}/doc/mainline.1 \
+ ${WRKSRC}/dosage/modules/__init__.py
+
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/mainline.1 ${PREFIX}/man/man1