aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/wyrd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/wyrd/Makefile')
-rw-r--r--deskutils/wyrd/Makefile25
1 files changed, 23 insertions, 2 deletions
diff --git a/deskutils/wyrd/Makefile b/deskutils/wyrd/Makefile
index e1b92840d00d..81eb4f69b925 100644
--- a/deskutils/wyrd/Makefile
+++ b/deskutils/wyrd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wyrd
-PORTVERSION= 1.4.2
+DISTVERSION= 1.4.3b
CATEGORIES= deskutils
MASTER_SITES= http://www.eecs.umich.edu/~pelzlpj/wyrd/
@@ -16,12 +16,33 @@ COMMENT= A curses front end to remind
BUILD_DEPENDS= ${LOCALBASE}/bin/ocamlc:${PORTSDIR}/lang/ocaml
RUN_DEPENDS= ${LOCALBASE}/bin/remind:${PORTSDIR}/deskutils/remind
+OPTIONS= UTF8 "Enable UTF-8 support" off
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
MAN1= wyrd.1
MAN5= wyrdrc.5
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
+WITH_NCURSES_PORT=yes
+.endif
+
+.if defined(WITH_UTF8)
+CONFIGURE_ARGS+=--enable-utf8
+.if defined(WITH_NCURSES_PORT)
+LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
+NCURSES_INC= ncurses/
+.endif
+.else
+CONFIGURE_ARGS+=--disable-utf8
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|ncursesw/|${NCURSES_INC}|' ${WRKSRC}/configure
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wyrd.opt ${PREFIX}/bin/wyrd
${INSTALL_DATA} ${WRKSRC}/wyrdrc ${PREFIX}/etc/wyrdrc
@@ -34,4 +55,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/manual.pdf ${DOCSDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>