aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gnustep-wrapper/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/deskutils/gnustep-wrapper/Makefile b/deskutils/gnustep-wrapper/Makefile
index 2fc8af50232a..9c02af04ae6b 100644
--- a/deskutils/gnustep-wrapper/Makefile
+++ b/deskutils/gnustep-wrapper/Makefile
@@ -25,13 +25,14 @@ ADDITIONAL_LIB_DIRS+= -L${WRKSRC}/libGSWrapper/obj
MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
MAKE_FLAGS+= debug=no
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|cp -u|#cp -p|' \
${WRKSRC}/WrapperFactory/GNUmakefile.postamble
+ ${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
+ ${WRKSRC}/GNUmakefile
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/Launcher/obj/GSWrapper_Launcher \
- ${GNUSTEP_SYSTEM_ROOT}/Applications/WrapperFactory.app/Resources/
+ ${STAGEDIR}${GNUSTEP_SYSTEM_ROOT}/Applications/WrapperFactory.app/Resources/
.include <bsd.port.mk>