aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/growl-for-linux/Makefile5
-rw-r--r--deskutils/multisync/Makefile6
2 files changed, 3 insertions, 8 deletions
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index 6c0fe58a749d..d9ca779f4fe2 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -15,8 +15,6 @@ BUILD_DEPENDS= desktop-file-install:${PORTSDIR}/devel/desktop-file-utils
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-AUTOMAKE_ARGS= -a -c -f
-
CONFIGURE_ARGS= OPENSSL_CFLAGS="-I${OPENSSLINC}" OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
GH_ACCOUNT= mattn
@@ -34,8 +32,7 @@ OPTIONS_DEFINE= LIBNOTIFY
PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,}
-USES= compiler:nestedfct libtool pkgconfig
-USE_AUTOTOOLS= aclocal autoconf automake libtoolize
+USES= autoreconf compiler:nestedfct libtool pkgconfig
USE_GITHUB= yes
USE_GNOME= gtk20
USE_OPENSSL= yes
diff --git a/deskutils/multisync/Makefile b/deskutils/multisync/Makefile
index 32650ea99e86..077596c12464 100644
--- a/deskutils/multisync/Makefile
+++ b/deskutils/multisync/Makefile
@@ -11,16 +11,14 @@ DISTNAME= multisync-${PORTVERSION}
MAINTAINER?= ports@FreeBSD.org
COMMENT?= Synchronize calendars, addressbooks, and other PIM data
+USES= autoreconf gmake libtool pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix libgnomeui
-USES= gmake libtool pathfix pkgconfig tar:bzip2
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= -a -c -f
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
-pre-configure:
+post-patch:
@${FIND} ${WRKDIR} -type l -delete
.include <bsd.port.mk>