aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ElectricFence
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ElectricFence')
-rw-r--r--devel/ElectricFence/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/devel/ElectricFence/Makefile b/devel/ElectricFence/Makefile
index 43a3e5f4a737..2b2422583d13 100644
--- a/devel/ElectricFence/Makefile
+++ b/devel/ElectricFence/Makefile
@@ -14,16 +14,14 @@ COMMENT= Debugging malloc() that uses the VM hardware to detect buffer overruns
USE_LDCONFIG= yes
CFLAGS+= -D__USE_BSD
-MAN3= efence.3
MAKE_ARGS= CC="${CC}"
-PLIST_FILES= bin/ef.sh lib/libefence.a lib/libefence.so.0
+PLIST_FILES= bin/ef.sh lib/libefence.a lib/libefence.so.0 man/man3/efence.3.gz
-NO_STAGE= yes
do-install:
- ${INSTALL_DATA} ${WRKSRC}/libefence.a ${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/libefence.so.0.0 ${PREFIX}/lib/libefence.so.0
- ${INSTALL_SCRIPT} ${WRKSRC}/ef.sh ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/efence.3 ${PREFIX}/man/man3
+ ${INSTALL_DATA} ${WRKSRC}/libefence.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/libefence.so.0.0 ${STAGEDIR}${PREFIX}/lib/libefence.so.0
+ ${INSTALL_SCRIPT} ${WRKSRC}/ef.sh ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/efence.3 ${STAGEDIR}${PREFIX}/man/man3
.include <bsd.port.mk>
/td> * - Set --mandir and --infodir in CONFIGURE_ARGS if the configure scriptrafan2007-07-231-2/+1 * - Really fix plist for goffice-0.4.1pav2007-07-221-1/+1 * - Update for goffice 0.4.1pav2007-07-152-3/+4 * - Update to 1.7.10pav2007-05-253-10/+13 * - Welcome X.org 7.2 \o/.flz2007-05-202-32/+1 * - Remove libgnomeprintui since gnumeric now uses GTK printahze2007-04-231-1/+1 * Update to 1.7.9ahze2007-04-223-9/+12 * Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOMEmarcus2007-03-194-39/+183 * INSTALLS_SHLIB -> USE_LDCONFIG.mezz2006-11-051-1/+1 * Fix internal path to the online help.marcus2006-06-041-1/+2 * Add a missing dependency on libgnomeui now that libgnomedb is no longermarcus2006-03-281-1/+1 * Add a forgotten '='.marcus2006-03-271-1/+1 * Turn the libgnomedb dependency into an OPTION.marcus2006-03-271-2/+3 * Optionalize libgnomedb support since libgda2 and libgda3 conflict.marcus2006-03-272-10/+22 * Update to 1.6.3.marcus2006-03-263-42/+4 * Conversion to a single libtool environment.ade2006-02-232-2/+40 * Fix build on 4.xjylefort2006-02-081-0/+35 * - Update to 1.6.2ahze2006-02-012-6/+5 * Update to 1.6.1.marcus2005-11-154-552/+10 * Fix build with goffice 0.1.1 [1].kwm2005-11-083-0/+547 * Update to 1.6.0.marcus2005-11-059-615/+509 * Add manual to update the mimetype database, bump the PORTREVISION.mezz2005-04-042-1/+5 * - Only remove locale directories if emptyahze2005-03-141-2/+2 * - Update to 1.4.3ahze2005-03-143-410/+416 * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-121-0/+1 * Update to 1.4.2.marcus2005-01-186-23/+25 * - Change forgotten PORTSNAME from gnumeric2 to gnumeric fromahze2004-12-201-3/+2 * Move math/gnumeric2 --> math/gnumericahze2004-12-1118-781/+565 * Unbreak with GCC 3.4.2.marcus2004-09-213-4/+37 * BROKEN on 5.x: Does not compilekris2004-09-191-1/+7 * - Use USE_ICONV knobkrion2004-03-311-1/+1