aboutsummaryrefslogtreecommitdiffstats
path: root/devel/Subversive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/Subversive/Makefile')
-rw-r--r--devel/Subversive/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/Subversive/Makefile b/devel/Subversive/Makefile
new file mode 100644
index 000000000000..9167feaaeaef
--- /dev/null
+++ b/devel/Subversive/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Subversive
+# Date created: 14 Feb 2007
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Subversive
+DISTVERSION= 1.1.0.RC5
+CATEGORIES= devel java
+MASTER_SITES= http://www.polarion.org/projects/subversive/download/1.1/builds/
+DISTNAME= ${PORTNAME}_${DISTVERSION}-LocalUpdateSite
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= An Eclipse plug-in that provides Subversion support
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
+ svn:${PORTSDIR}/devel/subversion
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s features plugins -not -type d) | \
+ ${SED} -ne 's,^,eclipse/,p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>