aboutsummaryrefslogtreecommitdiffstats
path: root/devel/agenda-libs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/agenda-libs/Makefile')
-rw-r--r--devel/agenda-libs/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/devel/agenda-libs/Makefile b/devel/agenda-libs/Makefile
index fabe8d0b408f..a50a46f9cb2b 100644
--- a/devel/agenda-libs/Makefile
+++ b/devel/agenda-libs/Makefile
@@ -6,25 +6,19 @@
#
PORTNAME= agenda-libs
-PORTVERSION= 1.0
+PORTVERSION= 1.2.0
CATEGORIES= devel
-MASTER_SITES= http://lev.serebryakov.spb.ru/download/agenda/
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
MAINTAINER= lev@serebryakov.spb.ru
-RUN_DEPENDS= ${LOCALBASE}/${TARGET_PLATFORM}/include/stdio.h:${PORTSDIR}/devel/agenda-headers
+RUN_DEPENDS= ${LOCALBASE}/mipsel-linux/lib/libc.a:${PORTSDIR}/devel/agenda-static-libs \
+ ${LOCALBASE}/mipsel-linux/lib/snow/libc.1.sso:${PORTSDIR}/devel/agenda-snow-libs
-TARGET_PLATFORM=mipsel-linux
-USE_BZIP2= yes
-NO_FILTER_SHLIBS= yes
-
-LIBC_SUB= PREFIX=${PREFIX} TARGET_PLATFORM=${TARGET_PLATFORM}
-
-do-build:
- @${SED} ${LIBC_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} < ${WRKSRC}/lib/libc.so > ${WRKSRC}/lib/libc.so.new
- @${MV} ${WRKSRC}/lib/libc.so.new ${WRKSRC}/lib/libc.so
+NO_BUILD= yes
do-install:
- (cd ${WRKSRC} && tar --exclude '*.orig' -cf - *) \
- | (cd ${PREFIX}/${TARGET_PLATFORM} && tar xf -)
+
.include <bsd.port.mk>