aboutsummaryrefslogtreecommitdiffstats
path: root/devel/allegro-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/allegro-devel/Makefile')
-rw-r--r--devel/allegro-devel/Makefile70
1 files changed, 51 insertions, 19 deletions
diff --git a/devel/allegro-devel/Makefile b/devel/allegro-devel/Makefile
index 501314c368ae..cb57c9061e1d 100644
--- a/devel/allegro-devel/Makefile
+++ b/devel/allegro-devel/Makefile
@@ -1,56 +1,88 @@
+# Created by: nemysis@gmx.ch
+#
# $FreeBSD$
+#
PORTNAME= allegro
-DISTVERSION= 4.4.2
-PORTREVISION= 1
+DISTVERSION= 5.0.7
CATEGORIES= devel
MASTER_SITES= SF/alleg/allegro/${PORTVERSION}
-PKGNAMESUFFIX= -devel
+PKGNAMESUFFIX= -devel5
MAINTAINER= nemysis@gmx.ch
COMMENT= Cross-platform library for games and multimedia programming
+LICENSE= BSD
+
+LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib \
+ jack.0:${PORTSDIR}/audio/jack \
+ png15:${PORTSDIR}/graphics/png \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ FLAC:${PORTSDIR}/audio/flac \
+ physfs.1:${PORTSDIR}/devel/physfs
+BUILD_DEPENDS= ${LOCALBASE}/bin/pandoc:${PORTSDIR}/textproc/hs-pandoc
+
USE_GMAKE= yes
-USES= cmake pkgconfig
+USE_CMAKE= yes
USE_XORG= x11 xpm xext xcursor xxf86vm xxf86dga
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
WANT_GNOME= yes
+USE_OPENAL= soft
USE_GL= gl glu
+USE_FREETYPE= yes
MAKE_JOBS_UNSAFE= yes
-PORTDOCS= *
-
CONFLICTS= allegro-[0-9]*
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
CMAKE_ARGS+= -DDOCDIR="${DOCSDIR}"
-SHLIB_VER= 4.4.2
+SHLIB_VER= 5.0.7
PORTSCOUT= limit:^4\.3\.[0-9]*
-CFLAGS+= -L${LOCALBASE}/lib
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib \
- jack.0:${PORTSDIR}/audio/jack \
- png15:${PORTSDIR}/graphics/png
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DEMOS
+OPTIONS_DEFAULT= DEMOS
+DEMOS_DESC= Install Demos programs
-.if ${PORT_OPTIONS:MDOCS}
+.include <bsd.port.options.mk>
.include "Makefile.man"
-INFO= allegro
-.endif
-post-patch:
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e 's|add_subdirectory(docs)|#add_subdirectory(docs)|' ${WRKSRC}/CMakeLists.txt
+.if ${PORT_OPTIONS:MDEMOS}
+CMAKE_ARGS+=-DWANT_DEMO=on
+PLIST_SUB+=DEMOS=""
+.else
+CMAKE_ARGS+=-DWANT_TESTS=off
.endif
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= CHANGES-5.0.txt CONTRIBUTORS.txt README.txt README_packaging.txt README_pkgconfig.txt
+
post-install:
-.if ${PORT_OPTIONS:MDOCS}
+ @${CP} -p ${WRKSRC}/allegro5.cfg ${PREFIX}/etc/allegro5.cfg.sample
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
+.endif
+
+.if ${PORT_OPTIONS:MDEMOS}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} demos ${EXAMPLESDIR})
+.endif
+
+.if ${PORT_OPTIONS:MMANPAGES}
@cd ${WRKSRC}/docs/man/ && \
${FIND} . -type f -and -name "*.3" -exec ${INSTALL_MAN} {} ${PREFIX}/man/man3/{} \;
.endif
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+ @(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} "src html" ${DOCSDIR})
+.endif
+
.include <bsd.port.mk>