aboutsummaryrefslogtreecommitdiffstats
path: root/devel/allegro/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/allegro/Makefile')
-rw-r--r--devel/allegro/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/devel/allegro/Makefile b/devel/allegro/Makefile
index 42be54b8909b..a9e8b7d344e5 100644
--- a/devel/allegro/Makefile
+++ b/devel/allegro/Makefile
@@ -20,8 +20,7 @@ USE_LDCONFIG= yes
USE_XLIB= yes
WANT_GNOME= yes
-OPTIONS= AL "Enable OpenAL support" off \
- ARTS "Enable Arts support" off \
+OPTIONS= ARTS "Enable Arts support" off \
DEBUG "Build debugging library" off \
DEVEL "Build development utilities" on \
ESOUND "Enable Esound support" off \
@@ -52,15 +51,6 @@ PORTSCOUT= limitw:1,even
EXTRA_PATCHES= ${FILESDIR}/extra-patch-include-allegro-inline-fmaths.in
.endif
-.if defined(WITH_AL)
-LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
-CONFIGURE_ARGS+=--enable-sgialdigi
-PLIST_SUB+= AL=""
-.else
-CONFIGURE_ARGS+=--disable-sgialdigi
-PLIST_SUB+= AL="@comment "
-.endif
-
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
CONFIGURE_ARGS+=--enable-artsdigi