aboutsummaryrefslogtreecommitdiffstats
path: root/devel/autoconf213/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/autoconf213/Makefile')
-rw-r--r--devel/autoconf213/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/devel/autoconf213/Makefile b/devel/autoconf213/Makefile
index 48984a9558a9..795de66d8fb2 100644
--- a/devel/autoconf213/Makefile
+++ b/devel/autoconf213/Makefile
@@ -7,7 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13.000227
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ade/gnu
@@ -17,32 +17,29 @@ MAINTAINER= ade@FreeBSD.org
COMMENT= Automatically configure source code on many Un*x platforms (2.13)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
+ autoconf-wrapper:${PORTSDIR}/devel/autoconf-wrapper
-BUILD_VERSION= 213
+BUILD_VERSION= 2.13
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
-LATEST_LINK= autoconf${BUILD_VERSION}
+LATEST_LINK= autoconf213
USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CONFIG_SHELL=${SH} M4=${LOCALBASE}/bin/gm4
-CONFIGURE_ARGS= --program-suffix=${BUILD_VERSION}
+CONFIGURE_ARGS= --program-suffix=-${BUILD_VERSION}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/autoconf
-INFO= autoconf${BUILD_VERSION}
+INFO= autoconf-${BUILD_VERSION}
+
+STRIP= # none
post-patch:
@${RM} ${WRKSRC}/*.info* >/dev/null 2>&1 || true
post-install:
- @${CHMOD} +x ${PREFIX}/share/autoconf${BUILD_VERSION}/config.*
+ @${CHMOD} +x ${PREFIX}/share/autoconf-${BUILD_VERSION}/config.*
@${INSTALL_SCRIPT} ${WRKSRC}/install-sh \
- ${PREFIX}/share/autoconf${BUILD_VERSION}
- @-${RM} -fr ${PREFIX}/libexec/autoconf${BUILD_VERSION}
- @${MKDIR} ${PREFIX}/libexec/autoconf${BUILD_VERSION}
-.for i in autoconf autoheader autoreconf autoscan autoupdate ifnames
- @${LN} -sf ${PREFIX}/bin/${i}${BUILD_VERSION} \
- ${PREFIX}/libexec/autoconf${BUILD_VERSION}/${i}
-.endfor
+ ${PREFIX}/share/autoconf-${BUILD_VERSION}
.include <bsd.port.mk>