aboutsummaryrefslogtreecommitdiffstats
path: root/devel/autoconf262
diff options
context:
space:
mode:
Diffstat (limited to 'devel/autoconf262')
-rw-r--r--devel/autoconf262/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/autoconf262/Makefile b/devel/autoconf262/Makefile
index 83f3fadd9c90..2554167af384 100644
--- a/devel/autoconf262/Makefile
+++ b/devel/autoconf262/Makefile
@@ -28,15 +28,18 @@ USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV+= CONFIG_SHELL=/bin/sh
+CONFIGURE_ENV+= M4=${LOCALBASE}/bin/gm4
+.if ${PORTNAME} == "autoconf"
.if exists(${LOCALBASE}/bin/emacs)
PLIST_SUB+= EMACS="" EMACSDIR=share/emacs
.elif exists(${LOCALBASE}/bin/xemacs)
PLIST_SUB+= EMACS="" EMACSDIR=lib/xemacs
.else
PLIST_SUB+= EMACS="@comment " EMACSDIR=""
-.endif
+.endif # no emacs found
+.endif # ${PORTNAME} == "autoconf"
GENERIC_TOOLS= config.guess \
config.sub \