aboutsummaryrefslogtreecommitdiffstats
path: root/devel/automake/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/automake/Makefile')
-rw-r--r--devel/automake/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/devel/automake/Makefile b/devel/automake/Makefile
index 3eaff14b70e2..eeef3583dc17 100644
--- a/devel/automake/Makefile
+++ b/devel/automake/Makefile
@@ -6,28 +6,27 @@
#
PORTNAME= automake
-PORTVERSION= 1.11.1
+PORTVERSION= 1.12
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= automake
DISTNAME= automake-${PORTVERSION}
MAINTAINER= autotools@FreeBSD.org
-COMMENT= GNU Standards-compliant Makefile generator (1.11)
+COMMENT= GNU Standards-compliant Makefile generator
RUN_DEPENDS= ${AUTOCONF_DEPENDS} \
automake-wrapper:${PORTSDIR}/devel/automake-wrapper
USE_AUTOTOOLS= autoconf:env
-BUILD_VERSION= 1.11
+BUILD_VERSION= 1.12
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
-LATEST_LINK= automake111
-USE_BZIP2= yes
+USE_XZ= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-suffix=-${BUILD_VERSION}
CONFIGURE_ENV+= MAKEINFO="makeinfo --no-split"
-INFO= automake-${BUILD_VERSION}
+INFO= automake
MAN1= aclocal-${BUILD_VERSION}-${BUILD_VERSION}.1 \
aclocal-${BUILD_VERSION}.1 \
automake-${BUILD_VERSION}-${BUILD_VERSION}.1 \
@@ -35,8 +34,6 @@ MAN1= aclocal-${BUILD_VERSION}-${BUILD_VERSION}.1 \
post-patch:
@${RM} ${WRKSRC}/doc/*.info
- @${MV} ${WRKSRC}/doc/automake.texi \
- ${WRKSRC}/doc/automake-${BUILD_VERSION}.texi
pre-su-install:
@${RM} -fr ${PREFIX}/share/automake-${BUILD_VERSION}