aboutsummaryrefslogtreecommitdiffstats
path: root/devel/automake110/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/automake110/Makefile')
-rw-r--r--devel/automake110/Makefile33
1 files changed, 12 insertions, 21 deletions
diff --git a/devel/automake110/Makefile b/devel/automake110/Makefile
index 281a5d2d3c58..4211f9fbd379 100644
--- a/devel/automake110/Makefile
+++ b/devel/automake110/Makefile
@@ -7,7 +7,7 @@
PORTNAME= automake
PORTVERSION= 1.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= automake
@@ -16,18 +16,19 @@ DISTNAME= automake-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
COMMENT= GNU Standards-compliant Makefile generator (1.10)
-RUN_DEPENDS= ${AUTOCONF_DEPENDS}
+RUN_DEPENDS= ${AUTOCONF_DEPENDS} \
+ automake-wrapper:${PORTSDIR}/devel/automake-wrapper
USE_AUTOTOOLS= autoconf:261:env
-BUILD_VERSION= 110
+BUILD_VERSION= 1.10
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
-LATEST_LINK= automake${BUILD_VERSION}
+LATEST_LINK= automake110
USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-suffix=${BUILD_VERSION}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-INFO= automake${BUILD_VERSION}
+INFO= automake-${BUILD_VERSION}
.include <bsd.port.pre.mk>
@@ -39,23 +40,13 @@ CONFIGURE_ENV+= MAKEINFO="makeinfo --no-split"
.endif
post-patch:
- @(cd ${WRKSRC}/doc && \
- ${RM} -f *.info && \
- ${MV} automake.texi automake${BUILD_VERSION}.texi && \
- ${REINPLACE_CMD} -E 's,(automake)\.(info),\1${BUILD_VERSION}\.\2,g' automake${BUILD_VERSION}.texi && \
- ${REINPLACE_CMD} -E 's,(automake)\.(info|texi),\1${BUILD_VERSION}\.\2,g' Makefile.in \
- )
+ @${RM} ${WRKSRC}/doc/*.info
+ @${MV} ${WRKSRC}/doc/automake.texi \
+ ${WRKSRC}/doc/automake-${BUILD_VERSION}.texi
pre-su-install:
- @${RM} -fr ${PREFIX}/share/automake${BUILD_VERSION}
- @${MKDIR} ${PREFIX}/share/automake${BUILD_VERSION}
- @${MKDIR} ${PREFIX}/share/aclocal${BUILD_VERSION}
- @${MKDIR} ${PREFIX}/libexec/automake${BUILD_VERSION}
-
-post-install:
-.for i in aclocal automake
- @${LN} -sf ${PREFIX}/bin/${i}${BUILD_VERSION} \
- ${PREFIX}/libexec/automake${BUILD_VERSION}/${i}
-.endfor
+ @${RM} -fr ${PREFIX}/share/automake-${BUILD_VERSION}
+ @${MKDIR} ${PREFIX}/share/automake-${BUILD_VERSION}
+ @${MKDIR} ${PREFIX}/share/aclocal-${BUILD_VERSION}
.include <bsd.port.post.mk>