aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boehm-gc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/boehm-gc/Makefile')
-rw-r--r--devel/boehm-gc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index 40777725ab40..b613c02e6cb4 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -31,10 +31,10 @@ OPTIONS= REDIRECT "Define malloc(3)-family replacements" off \
CONFIGURE_ARGS+= --enable-threads=posix --enable-thread-local-alloc
.if ${OSVERSION} < 502102
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} -lc_r"
+ LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lc_r/}"
.else
CONFIGURE_ENV= CFLAGSS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} -lpthread"
+ LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lpthread/}"
.endif
.if defined(WITH_PARALLEL_MARK)
CONFIGURE_ARGS+= --enable-parallel-mark