aboutsummaryrefslogtreecommitdiffstats
path: root/devel/boehm-gc
diff options
context:
space:
mode:
Diffstat (limited to 'devel/boehm-gc')
-rw-r--r--devel/boehm-gc/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index a09c81f9fc7c..4a2c0267858f 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -29,6 +29,13 @@ OPTIONS= REDIRECT "Define malloc(3)-family replacements" off \
.if defined(WITH_THREADING)
CONFIGURE_ARGS+= --enable-threads=posix --enable-thread-local-alloc
+.if ${OSVERSION} < 502102
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LIBS="${LIBS} -lc_r"
+.else
+CONFIGURE_ENV= CFLAGSS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LIBS="${LIBS} -lpthread"
+.endif
.if defined(WITH_PARALLEL_MARK)
CONFIGURE_ARGS+= --enable-parallel-mark
.endif