aboutsummaryrefslogtreecommitdiffstats
path: root/devel/bugzilla/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/bugzilla/Makefile')
-rw-r--r--devel/bugzilla/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index 3929c227a9f4..8a05b7ecfc2c 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -37,6 +37,9 @@ SUB_FILES= pkg-message
DATA_DIRS_LIST= images js skins
+# checksetup will fail if these directories are not present!
+EMPTY_DIRS_LIST=data graphs contrib lib t xt
+
.include "${.CURDIR}/Makefile.common"
.include "${.CURDIR}/Makefile.options"
.include <bsd.port.options.mk>
@@ -167,15 +170,13 @@ do-install: .SILENT
(cd ${WRKSRC}/${D} && ${COPYTREE_SHARE} . ${WWWDIR}/${D})
.endfor
${TAR} -C ${WRKSRC} -cf - Bugzilla template | ${TAR} --unlink -C ${WWWDIR} -xf -
+ @${MKDIR} ${EMPTY_DIRS_LIST:S!^!${WWWDIR}/!}
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
(cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} . ${DOCSDIR}/)
.endif
-# checksetup will fail if these directories are not present!
- ${MKDIR} ${WWWDIR}/contrib ${WWWDIR}/lib ${WWWDIR}/t ${WWWDIR}/xt
-
.if ${PORT_OPTIONS:MCONTRIB}
@cd ${WRKSRC}/contrib && \
${FIND} . -type d -exec ${MKDIR} "${WWWDIR}/contrib/{}" \; && \