aboutsummaryrefslogtreecommitdiffstats
path: root/devel/camomile/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/camomile/Makefile')
-rw-r--r--devel/camomile/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/camomile/Makefile b/devel/camomile/Makefile
new file mode 100644
index 000000000000..12eac8c5daae
--- /dev/null
+++ b/devel/camomile/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: camomile
+# Date created: Mar 17, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= camomile
+PORTVERSION= 0.4.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A comprehensive Unicode library for objective caml language
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+post-install:
+ @${ECHO_CMD} "@unexec ocamlfind remove camomile 2>/dev/null || true" >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>