aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cl-infix-sbcl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cl-infix-sbcl/Makefile')
-rw-r--r--devel/cl-infix-sbcl/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/devel/cl-infix-sbcl/Makefile b/devel/cl-infix-sbcl/Makefile
new file mode 100644
index 000000000000..fb1d149925f3
--- /dev/null
+++ b/devel/cl-infix-sbcl/Makefile
@@ -0,0 +1,42 @@
+# New ports collection Makefile for: cl-infix-sbcl
+# Date created: 13 Feb 2006
+# Whom: Pedro F Giffuni
+#
+# $FreeBSD$
+
+PORTNAME= infix
+DISTVERSION= 19960628
+CATEGORIES= devel lisp
+MASTER_SITES= http://ftp.linux.org.uk/pub/lisp/cclan/ \
+ ftp://ftp.ntnu.no/pub/lisp/cclan/ \
+ http://thingamy.com/cclan/ \
+ http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -sbcl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= giffunip@asme.org
+COMMENT= A lisp macro to read math statements in infix notation
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/infix/infix.asd:${PORTSDIR}/devel/cl-infix \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+
+NO_CDROM= No fees or compensation can be charged
+
+do-build:
+ WRKSRC=${WRKSRC}/ FBSD_ASDF_COMPILE_PORT=t\
+ sbcl --noinform --userinit /dev/null \
+ --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
+ --eval "(asdf:oos 'asdf:compile-op :infix)" \
+ --eval "(quit)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/infix/sbclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/infix/sbclfasl/
+
+.include <bsd.port.mk>
'>+3 * * reflect renaming on CPAN File-Spec to PathToolsskv2005-06-121-11/+5 * Update to 1.14erwin2004-10-252-3/+3 * Update to 1.13erwin2004-08-242-3/+3 * Fix Build with perl5.8mat2004-08-101-3/+4 * Correctly use bsd.port.(pre|post).mkerwin2004-07-141-1/+3 * Update to 1.12erwin2004-07-122-4/+5 * Update to 1.10erwin2004-03-262-3/+3 * Add size data, approved by maintainers.trevor2004-03-191-0/+1 * Update to 1.09erwin2003-12-092-2/+2 * Update to 1.08erwin2003-10-242-2/+2 * utilize SITE_PERLijliao2003-10-242-14/+13 * Update to 1.06erwin2003-07-182-2/+2 * Change to my FreeBSD.org addresserwin2003-06-131-1/+1 * 1. fix dependency for archivers/p5-Archive-Zip on 4.x with perl >= 5.6leeym2003-02-172-2/+2 * Simplify decection of File::Spec to avoid INDEX generation breakage.kuriyama2003-01-231-3/+2 * Use another File::Spec detection code same as p5-HTML-Template.kuriyama2003-01-131-10/+5 * Use File::Spec port only for perl < 5.8.alane2002-10-301-3/+13 * Update to 1.05.tobez2002-09-124-4/+5 * Update to version 1.03kevlo2002-09-033-4/+8 * Update to 1.01, assign the submitter to be the maintainer.tobez2002-06-052-3/+3 * upgrade to 1.00ijliao2002-04-292-2/+2