aboutsummaryrefslogtreecommitdiffstats
path: root/devel/clint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/clint/Makefile')
-rw-r--r--devel/clint/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/devel/clint/Makefile b/devel/clint/Makefile
index f8ebc9e43514..8f33ad52bc0a 100644
--- a/devel/clint/Makefile
+++ b/devel/clint/Makefile
@@ -17,21 +17,18 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A static source code checker for C++
USE_PYTHON= yes
-USE_LIBTOOL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
+INFO= clint
post-patch:
- @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
-
-post-install:
- @install-info ${PREFIX}/info/clint.info ${PREFIX}/info/dir
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-pedantic||g ; \
+ s|-ldl||g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>