aboutsummaryrefslogtreecommitdiffstats
path: root/devel/combat
diff options
context:
space:
mode:
Diffstat (limited to 'devel/combat')
-rw-r--r--devel/combat/Makefile53
-rw-r--r--devel/combat/distinfo2
-rw-r--r--devel/combat/files/patch-bin_idl2tcl30
-rw-r--r--devel/combat/files/patch-bin_iordump18
-rw-r--r--devel/combat/pkg-descr18
-rw-r--r--devel/combat/pkg-plist16
6 files changed, 0 insertions, 137 deletions
diff --git a/devel/combat/Makefile b/devel/combat/Makefile
deleted file mode 100644
index c6a4c62d6744..000000000000
--- a/devel/combat/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-# Created by: gahr
-# $FreeBSD$
-
-PORTNAME= combat
-PORTVERSION= 0.8.1
-CATEGORIES= devel
-MASTER_SITES= http://www.fpx.de/Combat/download/
-
-MAINTAINER= tcltk@FreeBSD.org
-COMMENT= A CORBA ORB implementation in Tcl
-
-LICENSE= BSD
-
-DEPRECATED= depends on expired devel/mico
-EXPIRATION_DATE=2014-01-22
-
-LIB_DEPENDS= libitcl.so:${PORTSDIR}/lang/itcl
-RUN_DEPENDS= idl:${PORTSDIR}/devel/mico
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-USES+= tcl:run
-NO_BUILD= yes
-
-PORTDOCS= *
-PORTEXAMPLES= *
-
-.include <bsd.port.options.mk>
-
-post-patch:
- ${FIND} ${WRKSRC} -name dotest | ${XARGS} \
- ${REINPLACE_CMD} -i '' -e 's|tclsh8.5|${TCLSH}|g'
- ${REINPLACE_CMD} -e 's|%%TCLSH%%|${TCLSH}|' \
- ${WRKSRC}/bin/idl2tcl ${WRKSRC}/bin/iordump
-
-do-install:
- cd ${WRKSRC}/orb && ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/lib/combat
- ${MKDIR} ${STAGEDIR}${PREFIX}/bin/combat
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/idl2tcl ${STAGEDIR}${PREFIX}/bin/combat
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/iordump ${STAGEDIR}${PREFIX}/bin/combat
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/combat.pdf ${STAGEDIR}${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/demo && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
-.endif
-
-regression-test:
- cd ${WRKSRC}/test && ${MAKE} test
-
-.include <bsd.port.mk>
diff --git a/devel/combat/distinfo b/devel/combat/distinfo
deleted file mode 100644
index 33eedb3d7713..000000000000
--- a/devel/combat/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (combat-0.8.1.tar.gz) = 1923fa19f55a03f720f0444d6edffe7dad246c2c4be82453b8d2c5b4922d99a8
-SIZE (combat-0.8.1.tar.gz) = 331808
diff --git a/devel/combat/files/patch-bin_idl2tcl b/devel/combat/files/patch-bin_idl2tcl
deleted file mode 100644
index 7c28fd5f0191..000000000000
--- a/devel/combat/files/patch-bin_idl2tcl
+++ /dev/null
@@ -1,30 +0,0 @@
---- bin/idl2tcl.orig 2011-08-01 20:00:08.000000000 +0200
-+++ bin/idl2tcl 2013-09-30 17:49:12.000000000 +0200
-@@ -1,14 +1,4 @@
--#! /bin/sh
--# $Id: idl2tcl,v 1.2 2011-08-01 18:00:08 fp Exp $ \
--# \
--# the next line restarts using tclsh8.5 on unix \
--if type tclsh8.5 > /dev/null 2>&1 ; then exec tclsh8.5 "$0" ${1+"$@"} ; fi
--# the next line restarts using tclsh85 on Windows using Cygwin \
--if type tclsh85 > /dev/null 2>&1 ; then exec tclsh85 "`cygpath --windows $0`" ${1+"$@"} ; fi
--# the next line complains about a missing tclsh \
--echo "This software requires Tcl 8.5 to run." ; \
--echo "Make sure that \"tclsh8.5\" or \"tclsh85\" is in your \$PATH" ; \
--exit 1
-+#!%%TCLSH%%
-
- #
- # ----------------------------------------------------------------------
-@@ -35,8 +25,9 @@
- }
-
- if {[catch {package require kill} oops]} {
-- puts stderr "Error: Failed to find the required \"kill\" package."
-- exit 1
-+ proc kill {pid} {
-+ exec kill $pid
-+ }
- }
-
- if {[catch {set argv [eval corba::init $argv]} res]} {
diff --git a/devel/combat/files/patch-bin_iordump b/devel/combat/files/patch-bin_iordump
deleted file mode 100644
index 3e293d3f41a9..000000000000
--- a/devel/combat/files/patch-bin_iordump
+++ /dev/null
@@ -1,18 +0,0 @@
---- bin/iordump.orig 2013-09-30 17:50:30.000000000 +0200
-+++ bin/iordump 2013-09-30 17:50:41.000000000 +0200
-@@ -1,14 +1,4 @@
--#! /bin/sh
--# $Id: iordump,v 1.1 2008-11-14 02:12:35 Owner Exp $ \
--# \
--# the next line restarts using tclsh8.5 on unix \
--if type tclsh8.5 > /dev/null 2>&1 ; then exec tclsh8.5 "$0" ${1+"$@"} ; fi
--# the next line restarts using tclsh85 on Windows using Cygwin \
--if type tclsh85 > /dev/null 2>&1 ; then exec tclsh85 "`cygpath --windows $0`" ${1+"$@"} ; fi
--# the next line complains about a missing tclsh \
--echo "This software requires Tcl 8.5 to run." ; \
--echo "Make sure that \"tclsh8.5\" or \"tclsh85\" is in your \$PATH" ; \
--exit 1
-+#!%%TCLSH%%
-
- #
- # ----------------------------------------------------------------------
diff --git a/devel/combat/pkg-descr b/devel/combat/pkg-descr
deleted file mode 100644
index d7ecf06d45a6..000000000000
--- a/devel/combat/pkg-descr
+++ /dev/null
@@ -1,18 +0,0 @@
-Combat is a CORBA Object Request Broker that allows the implementation of CORBA
-clients and servers in the Tcl programming language.
-
-On the client side, Combat is not only useful to easily test-drive existing
-CORBA servers, including the ability for rapid prototyping or to interactively
-interface with servers from a console, but makes Tcl an exciting language for
-distributed programming. Also, Tk allows to quickly develop attractive user
-interfaces accessing CORBA services. Server-side scripting using [incr Tcl]
-classes also offers a wide range of possibilities.
-
-Combat is compatible with the CORBA 3.0 specification including the IIOP
-protocol, and has been tested to interoperate with a wide range of open-source
-and commercial ORBs, including MICO, TAO and ORBexpress.
-
-Combat is written in pure Tcl, allowing it to run on all platforms supported by
-Tcl, which is a much wider range than supported by any other ORB.
-
-WWW: http://www.fpx.de/Combat/
diff --git a/devel/combat/pkg-plist b/devel/combat/pkg-plist
deleted file mode 100644
index 164b94050de0..000000000000
--- a/devel/combat/pkg-plist
+++ /dev/null
@@ -1,16 +0,0 @@
-bin/combat/idl2tcl
-bin/combat/iordump
-lib/combat/cdr.tcl
-lib/combat/codeset.tcl
-lib/combat/combat.tcl
-lib/combat/corba.tcl
-lib/combat/giop.tcl
-lib/combat/iiop.tcl
-lib/combat/iop.tcl
-lib/combat/object.tcl
-lib/combat/orb.tcl
-lib/combat/pkgIndex.tcl
-lib/combat/poa.tcl
-lib/combat/str.tcl
-@dirrm bin/combat
-@dirrm lib/combat