aboutsummaryrefslogtreecommitdiffstats
path: root/devel/commoncpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/commoncpp/Makefile')
-rw-r--r--devel/commoncpp/Makefile29
1 files changed, 14 insertions, 15 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index af12b45eb3b8..132988cce342 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= CommonC++
-PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTVERSION= 1.2.5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cplusplus
@@ -15,21 +14,21 @@ MASTER_SITE_SUBDIR= cplusplus
MAINTAINER= dyfet@gnu.org
USE_GMAKE= yes
+USE_CONFIGURE= yes
USE_LIBTOOL= yes
+#USE_AUTOCONF= yes
INSTALLS_SHLIB= yes
+#AUTOCONF= autoconf && ${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+# s|l\$$ost_cv_thread_library|\$$ost_cv_thread_library|g' \
+# ${WRKSRC}/configure
+#
+# I had immense problems with autoconf generated on xBSD 4.0 where the
+# generated configure would mangle library names.
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 411000
-CFLAGS+= -DUSE_FPATHCONF_HACK
-.endif
-
-pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \$$\(LT_RELEASE\)||g'
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
- s|l\$$ost_cv_thread_library|\$$ost_cv_thread_library|g ; \
- s|=c_r|=pthread|g' ${WRKSRC}/configure
+post-extract:
+ cd ${WRKSRC} ; ./configure
+# @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+# 's|-release \$$\(LT_RELEASE\)||g'
post-install:
.if !defined(NOPORTDOCS)
@@ -37,4 +36,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/commoncpp
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>