aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cpan-upload/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cpan-upload/Makefile')
-rw-r--r--devel/cpan-upload/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/cpan-upload/Makefile b/devel/cpan-upload/Makefile
new file mode 100644
index 000000000000..d2bd442d8c28
--- /dev/null
+++ b/devel/cpan-upload/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: cpan-upload
+# Date created: Nov 30 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpan-upload
+PORTVERSION= 2.2
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NE/NEILB/scripts/
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Script for uploading distributions to CPAN
+
+BUILD_DEPENDS= ${SITE_PERL}/AppConfig/Std.pm:${PORTSDIR}/devel/p5-AppConfig-Std \
+ ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser \
+ ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= cpan-upload.1
+
+.include <bsd.port.mk>