aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cscope/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cscope/Makefile')
-rw-r--r--devel/cscope/Makefile25
1 files changed, 22 insertions, 3 deletions
diff --git a/devel/cscope/Makefile b/devel/cscope/Makefile
index 850d6afb7164..131453378526 100644
--- a/devel/cscope/Makefile
+++ b/devel/cscope/Makefile
@@ -14,11 +14,30 @@ MASTER_SITES= SF
MAINTAINER= gahr@FreeBSD.org
COMMENT= An interactive C program browser
+OPTIONS= XCSCOPE "Install (X)Emacs package" off
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
-PLIST_FILES= bin/cscope \
- bin/ocs
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_XCSCOPE)
+PLIST_SUB+= XCSCOPE=""
+.else
+PLIST_SUB+= XCSCOPE="@comment "
+.endif
+
MAN1= cscope.1
-.include <bsd.port.mk>
+.if defined(WITH_XCSCOPE)
+post-install:
+ ${MKDIR} ${EMACSLISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/contrib/xcscope/xcscope.el ${EMACSLISPDIR}/
+ ${MKDIR} ${XEMACSLISPDIR}
+ ${LN} -sf ${EMACSLISPDIR}/xcscope.el ${XEMACSLISPDIR}
+.endif
+
+.include <bsd.port.post.mk>