aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cvsd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cvsd/Makefile')
-rw-r--r--devel/cvsd/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/devel/cvsd/Makefile b/devel/cvsd/Makefile
index 8c545ccb7ba9..09358a502693 100644
--- a/devel/cvsd/Makefile
+++ b/devel/cvsd/Makefile
@@ -7,31 +7,33 @@
#
PORTNAME= cvsd
-PORTVERSION= 0.9.14
+PORTVERSION= 0.9.16
CATEGORIES= devel
MASTER_SITES= http://tiefighter.et.tudelft.nl/~arthur/cvsd/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_PERL5= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-USE_PERL5= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-libwrap
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
MAN5= cvsd.conf.5
MAN8= cvsd.8 cvsd-buildroot.8 cvsd-passwd.8
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e \
- 's|@ACLOCAL@|${TRUE}|g ; \
- s|@AUTOCONF@|${TRUE}|g ; \
- s|@AUTOMAKE@|${TRUE}|g ; \
- s|@AUTOHEADER@|${TRUE}|g ; \
- s|init.d/cvsd|rc.d/cvsd.sh.sample|g ; \
+ @${REINPLACE_CMD} -e 's|init.d/cvsd|rc.d/cvsd.sh.sample|g ; \
s|init.d|rc.d|g' ${WRKSRC}/Makefile.in
post-install: