aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cvsnt
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cvsnt')
-rw-r--r--devel/cvsnt/Makefile2
-rw-r--r--devel/cvsnt/files/patch-lockservice-LockParse.cpp12
2 files changed, 13 insertions, 1 deletions
diff --git a/devel/cvsnt/Makefile b/devel/cvsnt/Makefile
index 262532946508..f2b4429be9fc 100644
--- a/devel/cvsnt/Makefile
+++ b/devel/cvsnt/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cvsnt
PORTVERSION= 2.0.58d
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= http://www.cvsnt.org/archive/
diff --git a/devel/cvsnt/files/patch-lockservice-LockParse.cpp b/devel/cvsnt/files/patch-lockservice-LockParse.cpp
new file mode 100644
index 000000000000..f24f80f0a862
--- /dev/null
+++ b/devel/cvsnt/files/patch-lockservice-LockParse.cpp
@@ -0,0 +1,12 @@
+--- lockservice/LockParse.cpp.orig Sun Feb 20 17:42:22 2005
++++ lockservice/LockParse.cpp Sun Feb 20 17:42:40 2005
+@@ -155,7 +155,8 @@
+ #ifdef _WIN32
+ this_clock = GetTickCount();
+ #else
+- this_clock = times(NULL);
++ struct tms tms_buf;
++ this_clock = times(&tms_buf);
+ #endif
+
+ if(this_clock<last_clock.clock)