aboutsummaryrefslogtreecommitdiffstats
path: root/devel/dreampie/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/dreampie/Makefile')
-rw-r--r--devel/dreampie/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/dreampie/Makefile b/devel/dreampie/Makefile
new file mode 100644
index 000000000000..97af940174da
--- /dev/null
+++ b/devel/dreampie/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: dreampie
+# Date created: 14 May 2010
+# Whom: Ju Pengfei <jupengfei@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dreampie
+PORTVERSION= 1.0.2
+CATEGORIES= devel python
+MASTER_SITES= http://launchpadlibrarian.net/40048492/
+
+MAINTAINER= jupengfei@gmail.com
+COMMENT= DreamPie is a Python shell which is designed to be reliable and fun
+
+USE_GNOME= pygtk2 pygtksourceview
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+MAN1= dreampie.1
+
+pre-patch:
+ @${REINPLACE_CMD} -e "s|share/man/man1|man/man1|" ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>