aboutsummaryrefslogtreecommitdiffstats
path: root/devel/elfrc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/elfrc/Makefile')
-rw-r--r--devel/elfrc/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/elfrc/Makefile b/devel/elfrc/Makefile
new file mode 100644
index 000000000000..e86428ea9518
--- /dev/null
+++ b/devel/elfrc/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: elfrc
+# Date created: 13 July 2007
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= elfrc
+PORTVERSION= 0.7
+CATEGORIES= devel
+MASTER_SITES= http://ktown.kde.org/~frerich/
+
+MAINTAINER= ed@fxq.nl
+COMMENT= Resource compiler for ELF systems
+
+PLIST_FILES= bin/elfrc
+PORTDOCS= README
+
+do-build:
+ @${ECHO} '#define ELFRC_VERSION "${PORTVERSION}"' > ${WRKSRC}/config.h
+ ${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/elfrc ${WRKSRC}/elfrc.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/elfrc ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= lack of ELF definitions (STV_DEFAULT) on FreeBSD < 6.0
+.endif
+
+.include <bsd.port.post.mk>