aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gnome-build/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gnome-build/Makefile')
-rw-r--r--devel/gnome-build/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/devel/gnome-build/Makefile b/devel/gnome-build/Makefile
index 0505ea17116f..d8280e1edbc5 100644
--- a/devel/gnome-build/Makefile
+++ b/devel/gnome-build/Makefile
@@ -18,17 +18,15 @@ LIB_DEPENDS= gdl.0:${PORTSDIR}/x11-toolkits/gdl
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
-GNU_CONFIGURE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomevfs bonobo libglade gal gtkhtml
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>