aboutsummaryrefslogtreecommitdiffstats
path: root/devel/goffice/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/goffice/Makefile')
-rw-r--r--devel/goffice/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/goffice/Makefile b/devel/goffice/Makefile
new file mode 100644
index 000000000000..82d10529f363
--- /dev/null
+++ b/devel/goffice/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: goffice
+# Date created: 07 June 2005
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/devel/goffice/Makefile,v 1.7 2005/10/11 22:26:02 marcus Exp $
+#
+
+PORTNAME= goffice
+PORTVERSION= 0.1.0
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.1
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GLib/GTK+ set of document centric objects and utilities
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprint libglade2 \
+ libgsf_gnome ltverhack
+USE_AUTOTOOLS= libtool:15
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_SUB= VERSION=${PORTVERSION}
+
+.include <bsd.port.mk>