aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gonzui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gonzui/Makefile')
-rw-r--r--devel/gonzui/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/devel/gonzui/Makefile b/devel/gonzui/Makefile
index e9c64d46fbb7..ce1053176e53 100644
--- a/devel/gonzui/Makefile
+++ b/devel/gonzui/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gonzui
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF
@@ -17,15 +17,24 @@ COMMENT= A source code search engine
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/bdb.so:${PORTSDIR}/databases/ruby-bdb \
${RUBY_ARCHLIBDIR}/iconv.so:${PORTSDIR}/converters/ruby-iconv
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/bdb.so:${PORTSDIR}/databases/ruby-bdb \
- ${RUBY_ARCHLIBDIR}/iconv.so:${PORTSDIR}/converters/ruby-iconv
+ ${RUBY_ARCHLIBDIR}/iconv.so:${PORTSDIR}/converters/ruby-iconv \
+ ${RUBY_SITELIBDIR}/langscan.rb:${PORTSDIR}/devel/ruby-langscan
USE_RUBY= yes
GNU_CONFIGURE= yes
+RUBY_SHEBANG_FILES= gonzui-db gonzui-import gonzui-remove \
+ gonzui-search gonzui-server gonzui-update
+
.include <bsd.port.pre.mk>
.if ${RUBY_VER} == 1.9
BROKEN= does not build with ruby 1.9
.endif
+post-configure:
+ ${REINPLACE_CMD} -e 's| langscan | |' \
+ -e 's| langscan.*\.rb||' \
+ ${WRKSRC}/Makefile
+
.include <bsd.port.post.mk>