aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hapy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hapy/Makefile')
-rw-r--r--devel/hapy/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/hapy/Makefile b/devel/hapy/Makefile
new file mode 100644
index 000000000000..9d968d8833a5
--- /dev/null
+++ b/devel/hapy/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: hapy
+# Date created: Dec 24, 2003
+# Whom: rousskov
+#
+# $FreeBSD$
+#
+
+PORTNAME= hapy
+PORTVERSION= 0.0.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Hapy-${PORTVERSION}
+
+MAINTAINER= rousskov@measurement-factory.com
+COMMENT= A runtime parser generator
+
+GNU_CONFIGURE= yes
+
+post-build:
+ @${ECHO_MSG} "Consider running 'make check' before 'make install'"
+ @${ECHO_MSG} "to execute a library self-test"
+
+check: build
+ cd ${WRKSRC}; ${MAKE} check
+
+.include <bsd.port.mk>