aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hapy
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hapy')
-rw-r--r--devel/hapy/Makefile27
-rw-r--r--devel/hapy/distinfo1
-rw-r--r--devel/hapy/pkg-descr9
-rw-r--r--devel/hapy/pkg-plist22
4 files changed, 59 insertions, 0 deletions
diff --git a/devel/hapy/Makefile b/devel/hapy/Makefile
new file mode 100644
index 000000000000..9d968d8833a5
--- /dev/null
+++ b/devel/hapy/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: hapy
+# Date created: Dec 24, 2003
+# Whom: rousskov
+#
+# $FreeBSD$
+#
+
+PORTNAME= hapy
+PORTVERSION= 0.0.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Hapy-${PORTVERSION}
+
+MAINTAINER= rousskov@measurement-factory.com
+COMMENT= A runtime parser generator
+
+GNU_CONFIGURE= yes
+
+post-build:
+ @${ECHO_MSG} "Consider running 'make check' before 'make install'"
+ @${ECHO_MSG} "to execute a library self-test"
+
+check: build
+ cd ${WRKSRC}; ${MAKE} check
+
+.include <bsd.port.mk>
diff --git a/devel/hapy/distinfo b/devel/hapy/distinfo
new file mode 100644
index 000000000000..c4d30e80f483
--- /dev/null
+++ b/devel/hapy/distinfo
@@ -0,0 +1 @@
+MD5 (Hapy-0.0.3.tar.gz) = 4f36fc3976f8c2bc7fb543e5c342c3e8
diff --git a/devel/hapy/pkg-descr b/devel/hapy/pkg-descr
new file mode 100644
index 000000000000..dc5a8dcfc02e
--- /dev/null
+++ b/devel/hapy/pkg-descr
@@ -0,0 +1,9 @@
+Hapy is a runtime parser generator library. The Hapy library
+generates parsers from BNF-like language grammars. Parsing
+scripting languages and communication protocol messages are
+typical use cases. Generated parsers are C++ objects. Hapy is
+public domain software.
+
+WWW: http://www.hapy.org/
+
+- Alex Rousskov
diff --git a/devel/hapy/pkg-plist b/devel/hapy/pkg-plist
new file mode 100644
index 000000000000..ee44461b7f9f
--- /dev/null
+++ b/devel/hapy/pkg-plist
@@ -0,0 +1,22 @@
+include/Hapy/Algorithm.h
+include/Hapy/Algorithms.h
+include/Hapy/Area.h
+include/Hapy/Assert.h
+include/Hapy/Buffer.h
+include/Hapy/IoStream.h
+include/Hapy/IosFwd.h
+include/Hapy/NumericLimits.h
+include/Hapy/Parser.h
+include/Hapy/Pree.h
+include/Hapy/PreeKids.h
+include/Hapy/Result.h
+include/Hapy/Rule.h
+include/Hapy/RuleBase.h
+include/Hapy/RuleId.h
+include/Hapy/RulePtr.h
+include/Hapy/Rules.h
+include/Hapy/String.h
+include/Hapy/Version.h
+include/Hapy/config.h
+lib/libHapy.a
+@dirrm include/Hapy