aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-bsd-sysctl
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-bsd-sysctl')
-rw-r--r--devel/hs-bsd-sysctl/Makefile4
-rw-r--r--devel/hs-bsd-sysctl/files/patch-Setup.hs16
2 files changed, 17 insertions, 3 deletions
diff --git a/devel/hs-bsd-sysctl/Makefile b/devel/hs-bsd-sysctl/Makefile
index 99d4e6aa87f0..8a0017bb4a32 100644
--- a/devel/hs-bsd-sysctl/Makefile
+++ b/devel/hs-bsd-sysctl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bsd-sysctl
PORTVERSION= 1.0.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
@@ -11,7 +11,5 @@ COMMENT= Access to the BSD sysctl(3) interface
LICENSE= BSD
-CABAL_SETUP= Setup.hs
-
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/devel/hs-bsd-sysctl/files/patch-Setup.hs b/devel/hs-bsd-sysctl/files/patch-Setup.hs
new file mode 100644
index 000000000000..5d8b6009497c
--- /dev/null
+++ b/devel/hs-bsd-sysctl/files/patch-Setup.hs
@@ -0,0 +1,16 @@
+--- ./Setup.hs.orig 2012-02-28 22:01:23.000000000 +0100
++++ ./Setup.hs 2013-05-01 00:55:07.000000000 +0200
+@@ -4,6 +4,7 @@
+
+ import System.Directory
+ import System.FilePath
++import System.IO.Error
+
+ -- Define __HADDOCK__ when building documentation.
+ main = defaultMainWithHooks simpleUserHooks {
+@@ -19,4 +20,4 @@
+ removePreProcessedFiles dir = do
+ putStrLn $ "Trying to remove source in: " ++ dir
+ removeFile (dir </> "System/BSD/Sysctl.hs")
+- `catch` \_ -> putStrLn "Could not find source file!" >> return ()
++ `catchIOError` \_ -> putStrLn "Could not find source file!" >> return ()